KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

win32_Exit_Code: 1067 (ERROR_DEVICE_NOT_CONNECTED)

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting
View previous topic :: View next topic  
Author Message
kvnsdr



Joined: 09 Apr 2004
Posts: 47

PostPosted: Fri Apr 23, 2004 7:52 pm    Post subject: win32_Exit_Code: 1067 (ERROR_DEVICE_NOT_CONNECTED) Reply with quote

I've purchased Hostmonitor 4.42 Enterprise w/ lifetime updates.

I have 6 out of 10 remote XP Pro workstations with failing RMAServices. They are on 10 seperate networks using seperate RMA's. They run very well for a week then one by one they fail for no obvious reason. I troubleshoot using: sc query RMAService and recieve the following Win32_Exit_Code: 1067 (ERROR_DEVICE_NOT_CONNECTED).

I think the RMAService disconnects when users reboot the workstations. For some reason the RMAService doesn't always start automatically as configured. The service is installed and configured properly for the other workstations with identical setups run flawlessly.

Mean while I've configured the 'KS Remote Monitoring Agent' 'Recovery' properties to 'Restart the service' after the first and second failures, then on the third failure to 'Restart the computer'. This is probably not the recommended fix, however for now the services are running.

Q. Have you heard of this before?

Q. Is this an XP Pro bug?
Back to top
View user's profile Send private message Visit poster's website
KS-Soft



Joined: 03 Apr 2002
Posts: 11947
Location: USA

PostPosted: Sun Apr 25, 2004 2:14 pm    Post subject: Reply with quote

Quote:
Q. Have you heard of this before?


No

Quote:
Q. Is this an XP Pro bug?


Hard to say. We do not have 10 XP systems, but I just tested RMA on 3 XP systems (restarted computers many times) - work fine.
Also I tried to find informaiton about similar problems with other applications under XP, found thousand links but there are different recommendations every time.

Is there any difference between you systems? E.g. SP2 on working system and SP1 on another systems? Or may be RMAs use different account?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
kvnsdr



Joined: 09 Apr 2004
Posts: 47

PostPosted: Thu Apr 29, 2004 5:55 pm    Post subject: Reply with quote

I've purchased Hostmonitor 4.42 Enterprise w/ lifetime updates.

I'm still having the same problems with some RMAs service stopping on my remote XP-Pro workstations. Until I set the 'Recovery' as "Restart the Service" in the RMA service properties, they used to simply stop. At least now they restart.

The errors seem to occur mostly, but not always when users log-off-on, not restart the PC, just simply switching users.

Q. What if I un-checked "Allow service to interact with desktop" for the RMA service?

For troubleshooting purposes I installed "Event Sentry" on the XP-Pro workstations to email me all Event Log errors. I compared the Log event emails with the RMA email alerts. Below are the Log enties I recieve just after an RMA fails.


Faulting application rma.exe, version 0.0.0.0, faulting module rma.exe, version 0.0.0.0, fault address 0x00028d90

The application, C:\Program Files\HostMonitor4\RMA-Win\rma.exe, generated an application error
The error occurred on 04/29/2004 @ 16:42:35.640
The exception generated was c0000005 at address 00428D90 (rma)

The KS Remote Monitoring Agent service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

Once again, the most interesting aspect is the RMA error problems are not present on all the workstations. Although all workstations are new and exact clones. Otherwise the workstations work flawlessly.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index