KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

ODBC Query test problem

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    KS-Soft Forum Index -> HostMonitor
View previous topic :: View next topic  
Author Message
Guido39



Joined: 17 Sep 2002
Posts: 65

PostPosted: Wed Jul 16, 2003 11:17 am    Post subject: Reply with quote

I'm starting of with a simple query to check a database for the existance of a domain name ("MR") in a field. The reply comes back with a different domain name but it still shows bad. I then put a name of "kahkhaskdh" which doesn't exist and it still comes back bad.

I have the test execute SQL query and said alert when field in row 1, column 1 is = to "kahkhaskdh". The reply comes back with a domain that is in the field but not equal to this.

Am I doing this wrong or not understanding how it works?
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12303
Location: USA

PostPosted: Wed Jul 16, 2003 12:21 pm    Post subject: Reply with quote

Does HostMonitor display value of the field in "Reply" columns? Could you please provide test settings (e.g. export test into text file)?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Guido39



Joined: 17 Sep 2002
Posts: 65

PostPosted: Thu Jul 17, 2003 10:54 am    Post subject: Reply with quote

Here are the details:

Method = ODBC
;--- Common properties ---
Title = ODBC: wslogdb50_jul2003
Comment = ODBC: wslogdb50_jul2003
RelatedURL =
ScheduleMode= Regular
Schedule =
Interval = 600
Alerts =
ReverseAlert= No
UnknownIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
;--- Test specific properties ---
Datasource = wslogdb50_jul2003
Login = xxxxxx
Password = xxxxxx
Timeout = 10
SQLQuery = SELECT USER_NAMES.[DOMAIN]FROM INCOMING INNER JOIN USER_NAMES ON INCOMING.USER_ID = USER_NAMES.USER_ID
CheckField = EqualTo
FieldRow = 1
FieldCol = 1
Value = fgdfgd

The reply is showing a domain name that exists in fieldrow 1 and fieldcol but it's not "fgdfgd". I would expect the status to be good then right?
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12303
Location: USA

PostPosted: Thu Jul 17, 2003 4:36 pm    Post subject: Reply with quote

I just exported your settings into HostMonitor 3.70, created database and changed data source. I kept rest of settings and test works correctly.
H'm, what version of HostMonitor do you use?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    KS-Soft Forum Index -> HostMonitor All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index