KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

Client Certificate not visible in HM

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports
View previous topic :: View next topic  
Author Message
Michael Siepen



Joined: 14 Sep 2009
Posts: 13
Location: Germany

PostPosted: Wed Feb 03, 2010 2:08 am    Post subject: Client Certificate not visible in HM Reply with quote

Hi,

I want to monitor an url which requests a client certificate. As mentioned in http://www.ks-soft.net/cgi-bin/phpBB/viewtopic.php?t=4625&highlight=certificates I installed the certificate and setup HM to use the local cert store but the dropdown menu is empty. I'm using HM 8.32 on windows xp sp2.
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Wed Feb 03, 2010 1:15 pm    Post subject: Reply with quote

HostMonitor is started as service or application?
If you enabled UseLocalCertStore opion then HostMonitor should be started under admin account.

What web browser do you use? Internet Explorer? Do you see this certificate on "Personal" tab in Certificated dialog window?
Can you send certificate to us for testing?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Michael Siepen



Joined: 14 Sep 2009
Posts: 13
Location: Germany

PostPosted: Thu Feb 04, 2010 1:32 am    Post subject: Reply with quote

I tried both application and service. Service started with system user and as administrator. At the moment it runs in application mode under a normal user account with local admin rights. This user sees the certificate on the personal tab in internet explorer and windows says everything is alright with it and that the user owns the private key.
I'm sorry I can't provide you with this certificate for security reasons.

*edit*
I issued a certificate for this user using our internal windows-ca and this isn't visible in HM, too. I can send you this certificate.
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Sun Feb 07, 2010 6:08 am    Post subject: Reply with quote

May be certificate is not marked as client certificate?
The object identifier for the Client Authentication certificate is 1.3.6.1.5.5.7.3.2. HostMonitor checks this OID.
You may try to disable this check: add FilterClientCertificates=0 line into [Misc] section of hostmon.ini file and restart HostMonitor. In such case HostMonitor will display all installed certificates.
Also you may remove UseLocalCertStore=1 option.

If this will not help, please send certificate to us.

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Michael Siepen



Joined: 14 Sep 2009
Posts: 13
Location: Germany

PostPosted: Mon Mar 01, 2010 2:20 am    Post subject: Reply with quote

Back from vacation I tried your hint, it works Thank you.
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Mon Mar 01, 2010 6:14 pm    Post subject: Reply with quote

You are welcome

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index