KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

Problems sending SMS, phone number isnt a valis integer

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports
View previous topic :: View next topic  
Author Message
quarkstrudel



Joined: 16 Sep 2009
Posts: 6

PostPosted: Wed Sep 16, 2009 8:47 am    Post subject: Problems sending SMS, phone number isnt a valis integer Reply with quote

When i try to send a sms via GSM i get the following message,
trying shorter numbers or (0172...) is the same result.


Sending...
Com port open .. Ok
Com port close .. Ok
Error: Cannot send message to +491720606191. '' is not a valid integer value

HostMonitor 8.14, Win XP SP3
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Wed Sep 16, 2009 10:50 am    Post subject: Reply with quote

Probably unexpected result on AT+CSMS command but I am not sure (need more information).

Could you please try test program www.ks-soft.net/download/test/GSMCenter.zip ?
Please, setup "SMS Log file" and "GSM-AT Logfile" files and try to send SMS.
Could you send the foregoing log files back to us?

What exactly GSM modem do you use?

Regards,
Alex
Back to top
View user's profile Send private message Visit poster's website
quarkstrudel



Joined: 16 Sep 2009
Posts: 6

PostPosted: Fri Sep 18, 2009 12:47 am    Post subject: This is what i get with gsmcenter Reply with quote

Thanks for the immediate reply,


I tried gsmcenter, first it seems not to work on com's > 9 on myPC.
On the target pc with com2 it works in general. After asking to connect the device i receive the same message ""it's not an integer value"

Currently i use an huawei E169 usb stick modem, working well withh a lot of standard sms software, even with sony or nokia command sets selected.
I tried all modem selections you offer, but always the same result.


this is the gsm log i get,
18.09.2009 08:34:09: ATE1

18.09.2009 08:34:09: OK
18.09.2009 08:34:09: AT+CREG?

18.09.2009 08:34:09: +CREG: 1,1
18.09.2009 08:34:09:
18.09.2009 08:34:09: OK
18.09.2009 08:34:09: AT+CREG=1

18.09.2009 08:34:09: OK
18.09.2009 08:34:09: AT+CPMS?

18.09.2009 08:34:09: +CPMS: "SM",0,30,"SM",0,30,"SM",0,30
18.09.2009 08:34:09:
18.09.2009 08:34:09: OK
18.09.2009 08:34:09: AT+CSMS?

18.09.2009 08:34:09: +CSMS: ,1,1,1
18.09.2009 08:34:09:
18.09.2009 08:34:09: OK
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Sun Sep 20, 2009 10:17 am    Post subject: Reply with quote

Could you please replace file KSGsmXLib.ocx (located in HostMonitor folder) with new version located at www.ks-soft.net/download/KSGsmXLib08.zip
You should stop HostMonitor, decompress (unzip) KSGsmXLib08.zip into HostMonitor folder and start HostMonitor again.

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
quarkstrudel



Joined: 16 Sep 2009
Posts: 6

PostPosted: Mon Sep 21, 2009 3:39 am    Post subject: success in small steps, Reply with quote

thanks for prompt answer and the patch, i got good and bad news.

sending sms now works without "integer error" , i received all sms, but only via test button on the action properties window.

Sending sms on alert from the Application wont work, no sms received, no error msg. An alert with sending both, mail and sms profile, did the email well, but no sms was sent.

I tried some different modems and settings, no success, no changes.

do you have any suggestions,


regards,

Manfred
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Mon Sep 21, 2009 10:44 pm    Post subject: Reply with quote

Could you please check Quick Log for this test (using "show actions" mode)? Do you see messages like "SMS ... has been passed to SMS control module"?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
quarkstrudel



Joined: 16 Sep 2009
Posts: 6

PostPosted: Tue Sep 22, 2009 1:03 am    Post subject: Reply with quote

Hello,

yes, this are the messages i got

E-mail to ithot@xxxx.com has been sent (via cfsvrex)
SMS +49172xxxxxx has been passed to SMS control module



regards,
Manfred
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Tue Sep 22, 2009 6:43 pm    Post subject: Reply with quote

This means HostMonitor is able to load and use KSGsmXLib.ocx just fine..
So, you are using the same phone and message class (e.g. "display immediately") for action and "SMS Test" dialog? in case of action you do not receive SMS and you do not see any error in SMS Log file (specified in Options dialog on SMS:GSM page)? That's strange... Could you set "SMS log: Detailed tech info" option, execute action and check SMS log again? Nothing??
Then could you add ForceQueueWaitResult DWORD value under
HKEY_LOCAL_MACHINE\SOFTWARE\KS-Soft\GSMX registry key:
value name: ForceQueueWaitResult
value type: DWORD
value: 1
then restart HostMonitor

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
quarkstrudel



Joined: 16 Sep 2009
Posts: 6

PostPosted: Wed Sep 30, 2009 2:58 am    Post subject: Reply with quote

Hello, after some busy days i came back to the SMS problem.

Thats what i did,
- first i started the test SMS, sms was sent successfully, smslog is ok
- second i started the alert, in the smslog is 'Message has been added to queue'
- i tried to start the test SMS again , result is 'Sending...Component is busy'

here is the sms log,

[30.09.2009 07:55:08] Sys SMS to +49172xxxxxx has been sent.
[30.09.2009 07:55:14] Sys Com port close .. Ok
[30.09.2009 07:55:14] Sys GSM modem deinitialization .. Ok
[30.09.2009 07:59:31] Sys Message has been added to queue
[30.09.2009 08:00:16] Sys Message has been added to queue

[30.09.2009 08:09:35] Sys Message has been added to queue
[30.09.2009 08:09:52] Sys Component is busy
[30.09.2009 08:10:20] Sys Message has been added to queue
[30.09.2009 08:11:05] Sys Message has been added to queue


I tryed the registry key, there is no GSMX folder in the registry , i created it but i got no additional results.

regards

Manfred
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Thu Oct 01, 2009 3:52 pm    Post subject: Reply with quote

Sorry for delay, its hard to fix problem when we cannot reproduce it...
Could you please try to replace KSGsmXLib.ocx located in HostMonitor folder using new version
http://www.ks-soft.net/download/test/ksgsmxlib11.zip
Please stop HostMonitor, extract KSGsmXLib.ocx file from archive, replace old KSGsmXLib.ocx then start HostMonitor.

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
quarkstrudel



Joined: 16 Sep 2009
Posts: 6

PostPosted: Fri Oct 02, 2009 1:08 am    Post subject: Reply with quote

G R E A T

i will do some more tests next week,
but for the moment
it is working !!!
thanks a lot for your effort, i will order the Software next week,

Regards

Manfred
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12337
Location: USA

PostPosted: Fri Oct 02, 2009 10:15 am    Post subject: Reply with quote

Finally!
Thank you for the notice

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index