KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

Set Up Monitoring of Backup Exec Service/Jobs via NTLog Test

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting
View previous topic :: View next topic  
Author Message
compudox



Joined: 07 Aug 2007
Posts: 5

PostPosted: Thu Aug 09, 2007 1:51 pm    Post subject: Set Up Monitoring of Backup Exec Service/Jobs via NTLog Test Reply with quote

New to Host Monitor and would like to set up tests to email me when the BackUp Exec service Stops or Starts and when a nightly backup job runs
successfully or fails. Can anyone offer suggestions. I have tried setting
up several variations of this test but none work exactly as I want them to.
Thanks in advance for any help that is provided me.

Sean
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12505
Location: USA

PostPosted: Thu Aug 09, 2007 4:55 pm    Post subject: Reply with quote

There are various solutions: you may check text logs or setup Backup Exec to send SNMP Trap messages and use SNMP Trap test method to receive such messages.
More details available at
http://www.ks-soft.net/cgi-bin/phpBB/viewtopic.php?t=1183

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
KS-Soft Europe



Joined: 16 May 2006
Posts: 2832

PostPosted: Fri Aug 10, 2007 1:14 am    Post subject: Re: Set Up Monitoring of Backup Exec Service/Jobs via NTLog Reply with quote

compudox wrote:
I have tried setting
up several variations of this test but none work exactly as I want them to.
As I understand, you have tried to setup the "NT Event Log test" method, right? Could you explain what is wrong? Could you provide the settings, you have specified for the "NT Event Log" test method? What exact status does HostMonitor show for that particular test?
Please note: HostMonitor changes test status to "Bad" only when it has found NEW event(s) that satisfies all specified requirements. If, after the next probe, the monitor does not find a new "Bad" event, it changes the test status to "Ok". http://www.ks-soft.net/hostmon.eng/mframe.htm#tests.htm#chkNTLog

Regards,
Max
Back to top
View user's profile Send private message Send e-mail Visit poster's website
compudox



Joined: 07 Aug 2007
Posts: 5

PostPosted: Mon Aug 13, 2007 2:42 pm    Post subject: Reply with quote

My apologies for the delay in response.
Sanitized Test Settings are Below:

; ------- Test #01 -------


Method = NTLog
;--- Common properties ---
DestFolder = Root\XX CXXXXX\Hosts\Servers\FSC\
RMAgent = 192.168.XXX.X
Title = NTLog \\Host:Backup Exec Bad Status
Comment = NTLog \\Host:Backup Exec
RelatedURL =
ScheduleMode= Regular
Schedule = 7 Days, 24 Hours
Interval = 43200
Alerts = Send Service Status Bad Email
ReverseAlert= No
UnknownIsBad= Yes
WarningIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
;--- Test specific properties ---
Computer = \\Host
Log = Application
Source = Backup Exec
Username = UserID
Password = Password
CheckComp = AnyFromList
CheckType = AnyFromList
CheckID = AnyFromList
CheckDescr = AnyFromList
CompList = ^M\\Host^M
TypeList = Error
TypeList = Warning
TypeList = Information
IDList = ^M34113^M57997^M
DescrList = ^MBackup Exec Alert: Service Stop^MBackup Exec Alert: Job Failed^M
ReportMode = LastEvent

The Backup Exec Job fails and no email is sent and the status stays at OK.
Also you state that the tests will only report on "Bad" events, so it will not report if the Service starts or the job completes successfully? Correct?

Thanks,

Sean
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12505
Location: USA

PostPosted: Mon Aug 13, 2007 5:36 pm    Post subject: Reply with quote

Quote:
The Backup Exec Job fails and no email is sent and the status stays at OK.

1) I think there is mistake. As I know Backup Exec uses ID 57797 for "Service Stop" event (not 57997)
2) Also I think you may use "Description contains: Any text" filter mode. You are filtering events by ID, that ID identifies unique events so you don't need to check descriptions.

Quote:
Also you state that the tests will only report on "Bad" events, so it will not report if the Service starts or the job completes successfully? Correct?

Not exactly.
1) What event is "bad" and what event is "good", its up to you. You are the one who setup the filter.
2) We said "HostMonitor changes test status to Bad only when it has found NEW event(s) that satisfies all specified requirements." Keyword is "NEW". In other words, HostMonitor does not checks events that where recorded before you setup test.

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
lee



Joined: 03 May 2007
Posts: 4

PostPosted: Mon Aug 20, 2007 7:35 am    Post subject: Reply with quote

This is what I use (have just come back into using HostMonitor literally today though, but this is what's been sitting in my tests for the past six months, alebit inactive):

Code:
Method      = NTLog
;--- Common properties ---
;DestFolder = Root\
RMAgent     = My SBS
Title       = Backup failure
Comment     = An event relating to failed backup is in the event log
RelatedURL  =
ScheduleMode= Regular
Schedule    = 7 Days, 24 Hours
Interval    = 21600
Alerts      = Message, Sound
ReverseAlert= No
UnknownIsBad= Yes
WarningIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Full
CommLogMode = Default
;--- Test specific properties ---
Computer    =
Log         = Application
Source      =
CheckComp   = Any
CheckType   = Any
CheckID     = AnyFromList
CheckDescr  = Any
CompList    =
TypeList    = Error
IDList      = ^M34113^M34338^M57348^M58053^M57751^M34114^M58057^M34578^M
DescrList   =
ReportMode  = LastEvent


This one was also in there, check once a day to see if the 'backup completed' event is NOT present:

Code:
Method      = NTLog
;--- Common properties ---
;DestFolder = Root\
RMAgent     = My SBS
Title       = Missing 'backup completed' event
Comment     = Event 34112 (backup completed successfully) not in app event log
RelatedURL  =
ScheduleMode= OneTestPerDay
ScheduleTime= 09:00:00
Alerts      = 'Backup complete' event missing
ReverseAlert= Yes
UnknownIsBad= Yes
WarningIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
;--- Test specific properties ---
Computer    =
Log         = Application
Source      =
CheckComp   = Any
CheckType   = Any
CheckID     = AnyFromList
CheckDescr  = Any
CompList    =
TypeList    = Information
IDList      = ^M34112^M
DescrList   =
ReportMode  = LastEvent


Hope that this is of some use to you. Corrections, amendments and alternate versions welcome.
Back to top
View user's profile Send private message
compudox



Joined: 07 Aug 2007
Posts: 5

PostPosted: Tue Aug 21, 2007 8:22 am    Post subject: Reply with quote

Thanks, I will take a look at this and give it a try.

Sean
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index