KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

Text log test fails on linux agent

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting
View previous topic :: View next topic  
Author Message
dpeterka2



Joined: 06 Feb 2007
Posts: 8

PostPosted: Tue Feb 06, 2007 3:25 pm    Post subject: Text log test fails on linux agent Reply with quote

Running a text log test on a debian server with RMA agent installed, fails with the following reply:
'' is not a valid integer

I've tried alternate files and screwed around with this and that but to know avail.
RMA Is: 1.2.3
HM is: 6.52
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12094
Location: USA

PostPosted: Tue Feb 06, 2007 3:30 pm    Post subject: Reply with quote

May be its not RMA problem. Probably you are using invalid expression for "Use Warning status"/"Use Normal status" options?
May I see test settings? You may export test settings into text file using menu File -> Export into text file.

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
dpeterka2



Joined: 06 Feb 2007
Posts: 8

PostPosted: Tue Feb 06, 2007 3:34 pm    Post subject: Test settings Reply with quote

;-----------------------------------------------------------------------------
;- HostMonitor`s export/import file -
;- Generated by HostMonitor at 2/6/2007 4:33:49 PM -
;- Source file: C:\HostMonitor\TestLists\primary.hml -
;- Generation mode: Selected_Tests -
;-----------------------------------------------------------------------------


; ------- Test #01 -------


Method = TextLog
;--- Common properties ---
;DestFolder = Root\RackSpace\Applications\Dashboard\
RMAgent = prdweb1
Title = prdweb apache log mysql error test
Comment = TextLog: /home/spark/dashboard/logs/error_log
RelatedURL =
ScheduleMode= Regular
Schedule =
Interval = 600
Alerts = Ajay
ReverseAlert= No
UnknownIsBad= Yes
WarningIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
SyncCounters= Yes
SyncAlerts = No
DependsOn = list
MasterTest-Alive = prdweb2 HTTP Test
;--- Test specific properties ---
File = /tmp/error_log
FileMacros = No
LookFor = mysql
LookMode = String
MatchCase = No
WholeWord = No
UseMacros = No
AlertMode = LastEvent
ReplyMode = Line
ReplyFilter = WholeLine
ReplyRange1 = 1
ReplyRange2 = 0

;-----------------------------------------------------------------------------
; Exported 1 items
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12094
Location: USA

PostPosted: Tue Feb 06, 2007 5:04 pm    Post subject: Reply with quote

We cannot reproduce the problem. Could you send log file (/tmp/error_log ) to support@ks-soft.net?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
KS-Soft



Joined: 03 Apr 2002
Posts: 12094
Location: USA

PostPosted: Wed Feb 07, 2007 11:46 am    Post subject: Reply with quote

We tried RMA on RedHat and Mandrake - cannot reproduce the problem.
What exactly binary module do you use? There are some modules compiled on our machines and some modules compiled by customers
http://www.ks-soft.net/hostmon.eng/downpage.htm
Could you provide download link you have used?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index