KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

URL test problem after upgrade to version 6.42c
Goto page 1, 2  Next
 
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting
View previous topic :: View next topic  
Author Message
csk026



Joined: 29 Apr 2002
Posts: 25

PostPosted: Mon Jan 15, 2007 3:39 am    Post subject: URL test problem after upgrade to version 6.42c Reply with quote

Dear Sir
After we upgrade to version 6.42c we have problem with URL test.
The site is alive and we get frequently bad status for the test.
(We can access the site using IE6).


Regards

shlomo.koren@motorola.com
Back to top
View user's profile Send private message Send e-mail
KS-Soft Europe



Joined: 16 May 2006
Posts: 2832

PostPosted: Mon Jan 15, 2007 8:32 am    Post subject: Re: URL test problem after upgrade to version 6.42c Reply with quote

csk026 wrote:
After we upgrade to version 6.42c we have problem with URL test.
The site is alive and we get frequently bad status for the test.

Hm. We have not changed these tests since version 6.00
Could you provide the URL link you monitor? Could it be a temporary network problems? Is the HostMonitor running on the server in the same network, where your machine is located? Have you tested access using IE6 from your machine or from the server where HostMonitor is running?
What exact status do you see? Bad? Unknown? Do you see any errors in Reply field?

Regards,
Max
Back to top
View user's profile Send private message Send e-mail Visit poster's website
JuergenF



Joined: 26 Jan 2003
Posts: 331
Location: Germany, North Rhine-Westphalia

PostPosted: Mon Jan 15, 2007 1:06 pm    Post subject: Reply with quote

Hi Max,

I've a similar problem.
I can't tell you, since which version number that started.
The test fails continously. I think it's running into timeout.
Opening IE from the HostMonitor machine works fine all the time and very quickly (so network problem can be sorted out)
HM is running as service.
Status: No Answer (and that seems True. A check lasts 10 seconds)
Reply field: Is empty

Code:
;-----------------------------------------------------------------------------
;- HostMonitor`s export/import file                                          -
;- Generated by HostMonitor at 2007-01-15 20:03:04                           -
;- Source file: E:\Program Files\HostMonitor\DCC-Network.hml                 -
;- Generation mode: Selected_Tests                                           -
;-----------------------------------------------------------------------------


; ------- Test #01 -------


Method      = Url
;--- Common properties ---
;DestFolder = DCC\
Title       = SAP-Bibliothek
Comment     = SAP-Bibliothek
RelatedURL  = http://195.233.60.154/46c/helpdata/DE/e1/8e51341a06084de10000009b38f83b/frameset.htm
ScheduleMode= Regular
Schedule    = 7 Days, 24 Hours
Interval    = 600
Alerts      = Gen.HTML report-Retest-Alarm after 3
ReverseAlert= No
UnknownIsBad= Yes
WarningIsBad= No
UseWarning  = No
WarningExpr = %udv_status_bad%
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
;--- Test specific properties ---
URL         = http://195.233.60.154/46c/helpdata/DE/e1/8e51341a06084de10000009b38f83b/frameset.htm
UrlUseMacros= No
is302ok     = Yes
IgnoreUnknCA= No
Timeout     = 10000
UseFrames   = No
UseImages   = No
CheckContents = contain
Expression    = SAP-Bibliothek
CaseSensitive = No
WholeWordsOnly= No
ExprUseMacros = No

;-----------------------------------------------------------------------------
; Exported 1 items
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12606
Location: USA

PostPosted: Mon Jan 15, 2007 1:47 pm    Post subject: Reply with quote

We changed nothing in the code for long time. On the other hand URL test uses Windows wininet.dll, this means Windows updates may effect the result.
Could you try HTTP test? It uses our own code and winsock API.
Can we access your web site for testing?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
JuergenF



Joined: 26 Jan 2003
Posts: 331
Location: Germany, North Rhine-Westphalia

PostPosted: Mon Jan 15, 2007 3:05 pm    Post subject: Reply with quote

Hi Alex

Code:
;-----------------------------------------------------------------------------
;- HostMonitor`s export/import file                                          -
;- Generated by HostMonitor at 2007-01-15 21:55:01                           -
;- Source file: E:\Program Files\HostMonitor\DCC-Network.hml                 -
;- Generation mode: Selected_Tests                                           -
;-----------------------------------------------------------------------------


; ------- Test #01 -------


Method      = HTTP
;--- Common properties ---
;DestFolder = DCC\
Title       = SAP-Bibliothek1
Comment     =
RelatedURL  = http://195.233.60.154/46c/helpdata/DE/e1/8e51341a06084de10000009b38f83b/frameset.htm
ScheduleMode= Regular
Schedule    =
Interval    = 600
Alerts      =
ReverseAlert= No
UnknownIsBad= Yes
WarningIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
;--- Test specific properties ---
URL         = http://195.233.60.154/46c/helpdata/DE/e1/8e51341a06084de10000009b38f83b/frameset.htm
Request     = GET
Redirect    = Yes
PostData    =
Agent       = KSHostMonitor:/1.0
Timeout     = 10000
AllowCookies= No
OtherHeaders=
AuthMethod  = None
CheckContents= mustcontain
CExpression = SAP-Bibliothek
CMatchCase  = No
CWholeWord  = No
UseFrames   = Yes
UseImages   = Yes

;-----------------------------------------------------------------------------
; Exported 1 items

Reply field: "Timed-out"
The Test-Button produces:
Test status: No answer
Error code: 1006
Error msg: Timed-out

When I change to "Request: HEADER"
Reply field: "Bad contents"
The Test-Button produces:
Test status: Bad contents
Error code: 0
Error msg:


Sorry the Server is not reachable from the Internet

Regards

Juergen
Back to top
View user's profile Send private message
csk026



Joined: 29 Apr 2002
Posts: 25

PostPosted: Tue Jan 16, 2007 1:53 am    Post subject: add http test and wait Reply with quote

Hi Alex
Sorry but you can not access the server out of the company.
I add the HTTP test and wait to fail event.

For more information I export tests information:

;-----------------------------------------------------------------------------
;- HostMonitor`s export/import file -
;- Generated by HostMonitor at 1/16/2007 9:45:39 AM -
;- Source file: C:\Program Files\HostMonitor5\dev2006.hml -
;- Generation mode: Selected_Tests -
;-----------------------------------------------------------------------------


; ------- Test #01 -------


Method = HTTP
;--- Common properties ---
;DestFolder = Root\Tel-Aviv\Pc\Services\
Title = HTTP: /mildc.mot.com
Comment = HTTP: http://mildc.mot.com
RelatedURL =
ScheduleMode= Regular
Schedule = 7 Days, 24 Hours
Interval = 180
Alerts = Do nothing
ReverseAlert= No
UnknownIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
SyncCounters= Yes
SyncAlerts = No
DependsOn = list
MasterTest-Alive = zil06web04- ping.
;--- Test specific properties ---
URL = http://mildc.mot.com
Request = HEADER
Redirect = Yes
PostData =
Agent = Mozilla/4.0 (compatible; MSIE 6.0)
Timeout = 5000
AllowCookies= No
OtherHeaders=
AuthMethod = None
UseFrames = No
UseImages = No


; ------- Test #02 -------


Method = Url
;--- Common properties ---
;DestFolder = Root\Tel-Aviv\Pc\Services\
Title = http://mildc.mot.com - URL request
Comment = http://mcil.mot.com (5Nine)
RelatedURL =
ScheduleMode= Regular
Schedule = 7 Days, 24 Hours
Interval = 180
Alerts = PcAdmins Priority alert high
ReverseAlert= No
UnknownIsBad= Yes
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
SyncCounters= Yes
SyncAlerts = No
DependsOn = list
MasterTest-Alive = zil06web04- ping.
;--- Test specific properties ---
URL = http://mildc.mot.com
UrlUseMacros= No
is302ok = Yes
IgnoreUnknCA= No
Timeout = 11000
UseFrames = No
UseImages = No

;-----------------------------------------------------------------------------
; Exported 2 items


Regards
Back to top
View user's profile Send private message Send e-mail
csk026



Joined: 29 Apr 2002
Posts: 25

PostPosted: Wed Jan 17, 2007 4:38 am    Post subject: Test HTTP also fail Reply with quote

Alex,
After i add HTTP test also ,I find that they fail at the time.
(The two tests get bad status)
Regards
Back to top
View user's profile Send private message Send e-mail
KS-Soft Europe



Joined: 16 May 2006
Posts: 2832

PostPosted: Wed Jan 17, 2007 5:22 am    Post subject: Re: Test HTTP also fail Reply with quote

csk026 wrote:
After i add HTTP test also ,I find that they fail at the time.
(The two tests get bad status)

What exact Web Server serves the web site you monitor? IIS? Appache? Any other? Juergen, could you provide the same information please?

Regards,
Max
Back to top
View user's profile Send private message Send e-mail Visit poster's website
csk026



Joined: 29 Apr 2002
Posts: 25

PostPosted: Wed Jan 17, 2007 5:34 am    Post subject: anonymous user problem Reply with quote

Alex,
I think i found the problem.
IIS anonymous user had a login problem.
First i add user authetication to HTTP test and it beging to get "good" status.
So i fixed the anonymos access and from now i will use HTTP test and not URL test.

Regards
Back to top
View user's profile Send private message Send e-mail
JuergenF



Joined: 26 Jan 2003
Posts: 331
Location: Germany, North Rhine-Westphalia

PostPosted: Wed Jan 17, 2007 7:46 am    Post subject: Re: Test HTTP also fail Reply with quote

KS-Soft Europe wrote:
What exact Web Server serves the web site you monitor? IIS? Appache? Any other? Juergen, could you provide the same information please?

Since yesterday the Website is not accessable at all.
The server is located at a provider site. At the moment I can't answer those questions. I'll try to find out (or may a Wireshark trace answer the questions, when the site is running again ?)

Regards

Juergen
Back to top
View user's profile Send private message
KS-Soft Europe



Joined: 16 May 2006
Posts: 2832

PostPosted: Wed Jan 17, 2007 9:12 am    Post subject: Re: anonymous user problem Reply with quote

csk026 wrote:
I think i found the problem.
IIS anonymous user had a login problem.
Glad it works.

JuergenF wrote:
Since yesterday the Website is not accessable at all.
Hm. Please, let us know if you manage to figure it out. Looks like it is not HostMonitor's problem.

Regards,
Max
Back to top
View user's profile Send private message Send e-mail Visit poster's website
KS-Soft



Joined: 03 Apr 2002
Posts: 12606
Location: USA

PostPosted: Wed Jan 17, 2007 11:01 am    Post subject: Reply with quote

Sure. URL and HTTP tests use completely different code. If both tests return "bad" status, there is some problem with the server.
BTW Sometimes IE does not request web server, it may use cache instead (even if you click Refresh)

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
JuergenF



Joined: 26 Jan 2003
Posts: 331
Location: Germany, North Rhine-Westphalia

PostPosted: Tue Jan 30, 2007 4:53 pm    Post subject: Reply with quote

Dear all,

the first site I mentioned is still down.
But today I had a similar problem with another Website (reachable from public Internet)

Both methods (HTTP and URL) show the same problem. The test ran into timeout.
It was working for days. Then it failed for hours.
Performing a manual test with IE6 from the HM Server works fine.
I stopped and started HM Service and the test is working again.
I have several URL/HTTP tests, all were working fine, except this one.
The same problem - with the same test - happened before and was fixed by restarting the service.
It's very strange.

https://www.demag-shop.com/dcc/index.html?Mandant=0040004

Code:
Method      = HTTP
;--- Common properties ---
;DestFolder = DCC\
Title       = DCDWZ058 - Demag Shop Anmeldung
Comment     = DCDWZ058 - Demag Shop Anmeldung
RelatedURL  = https://www.demag-shop.com/dcc/index.html?Mandant=0040004
ScheduleMode= Regular
Schedule    = 7 Days, 24 Hours
Interval    = 180
Alerts      = Gen.HTML report-Retest-Alarm after 3
ReverseAlert= No
UnknownIsBad= Yes
WarningIsBad= No
UseWarning  = Yes
WarningExpr = %udv_status_1_bad%
UseCommonLog= Yes
PrivLogMode = Default
CommLogMode = Default
SyncCounters= No
SyncAlerts  = No
DependsOn   = list
MasterTest-Alive = DCDWZ058 - Demag Shop (ping)
;--- Test specific properties ---
URL         = https://www.demag-shop.com/dcc/index.html?Mandant=0040004
Request     = GET
Redirect    = No
PostData    =
Agent       = KSHostMonitor:/1.0
Timeout     = 15000
AllowCookies= No
OtherHeaders=
AuthMethod  = None
CheckContents= mustcontain
CExpression = Login
CMatchCase  = No
CWholeWord  = No
UseFrames   = No
UseImages   = No
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12606
Location: USA

PostPosted: Wed Jan 31, 2007 5:24 pm    Post subject: Reply with quote

We have created several test items using your settings to check www.demag-shop.com. So far HostMonitor performed over 3,000 probes without "bad" result...

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
JuergenF



Joined: 26 Jan 2003
Posts: 331
Location: Germany, North Rhine-Westphalia

PostPosted: Thu Feb 01, 2007 6:59 am    Post subject: Reply with quote

KS-Soft wrote:
We have created several test items using your settings to check www.demag-shop.com. So far HostMonitor performed over 3,000 probes without "bad" result...

Regards
Alex


Many thanks.

I'll let you know, when I have the problem again

Juergen
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Configuration, Maintenance, Troubleshooting All times are GMT - 6 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index