KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

The variable %TestName% is not displayed

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports
View previous topic :: View next topic  
Author Message
cichockia



Joined: 19 Sep 2014
Posts: 26

PostPosted: Fri May 17, 2019 12:53 am    Post subject: The variable %TestName% is not displayed Reply with quote

Hello,
If I type variable %TestName% in the comment field is not substituted with the value of the name field test only the variable name.
The problem occurs from updating Hostmonitor to version 11.97.

System: Win2008
Hostmonitor ver 11.97

Regards
Artur
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12063
Location: USA

PostPosted: Fri May 17, 2019 4:52 am    Post subject: Reply with quote

Please check the manual.

There are list of variables that can be used in some test related fields
https://www.ks-soft.net/hostmon.eng/mframe.htm#tests.htm#templates

%TestName% can be used as parameter of the action
https://www.ks-soft.net/hostmon.eng/mframe.htm#actions.htm#macro

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
cichockia



Joined: 19 Sep 2014
Posts: 26

PostPosted: Mon May 20, 2019 1:10 am    Post subject: Reply with quote

Hello,
Strange, it worked so far. I have over 700 tests that use the %TestName% variable in the "comment" field.
I sent a screenshot to admin@ks-soft.net. The screenshot shows previous and current e-mails with the variable %TestName%
Regards
Artur
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 12063
Location: USA

PostPosted: Mon May 20, 2019 4:37 am    Post subject: Reply with quote

It should not work.
We did not receive your mail, could you please send screen shot to support@ks-soft.net?

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
KS-Soft



Joined: 03 Apr 2002
Posts: 12063
Location: USA

PostPosted: Mon May 20, 2019 7:18 am    Post subject: Reply with quote

Commentline3 = %TestName%, then %CommentLine3% used as e-mail subject.
Yes, officially this should not work.

But "unofficially" it could work before version 11.90.
In v11.90 we optimized some code to make HostMonitor faster, so now it works faster and accordingly to the manual.
Not a bug.

May be we can add some switch for you in next version but I am not sure, we want to make HostMonitor faster.
I think you may easily change action property - set %TestName% in subject field.

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
KS-Soft



Joined: 03 Apr 2002
Posts: 12063
Location: USA

PostPosted: Tue May 21, 2019 4:06 pm    Post subject: Reply with quote

We sent you link to update (by e-mail)

Regards
Alex
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index