KS-Soft. Network Management Solutions
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister    ProfileProfile    Log inLog in 

Test methods - VM Guests return Unauthorized via Agent

 
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports
View previous topic :: View next topic  
Author Message
seelye



Joined: 17 Sep 2005
Posts: 28
Location: USA

PostPosted: Fri Feb 12, 2016 7:44 pm    Post subject: Test methods - VM Guests return Unauthorized via Agent Reply with quote

Just upgraded to 10.08 and found what appears to be a bug with the RMA or how HM talks to the RMA.

Problem summary: Test Methods of VM guests __________ reply with Unauthorized when run via Agent.

HM Server: Windows Server 2008 R2
My environment: Host Monitor 10.08
Passive and Active Agents are all 5.04

Tests Methods affected (at least those I tested):
VM guests CPU usage
VM guests disk space
VM guests free memory
VM guests status

When any of these test methods are run using TestBy: HostMonitor, the reply contains valid results.

When any of these test methods are run using an Active or Passive Agent, the reply is Unauthorized

I've confirmed the RMA is configured to allow all test methods and also confirmed that other test methods are indeed working through these agents. The agents have been in place for quite some time.

It appears the VM credentials are not being properly processed via the Agent but are processed properly by HostMonitor.

Can you look into the programming or let me know if you need any additional information?

Thank you
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 11782
Location: USA

PostPosted: Sat Feb 13, 2016 7:27 am    Post subject: Reply with quote

Finally, 1st bug report
Thank you

As I understand you are using "Connect as" test property?
If you setup account using Connection Manager, then everything works fine, right?

Then you may apply this fix
www.ks-soft.net/download/hm1009.zip
Just unzip file and replace hostmon.exe module

Regards
Alex
Back to top
View user's profile Send private message Send e-mail Visit poster's website
seelye



Joined: 17 Sep 2005
Posts: 28
Location: USA

PostPosted: Sat Feb 13, 2016 3:54 pm    Post subject: Reply with quote

Alex,

Wow! I was first at something.

v10.09 did the trick! My VM Guests __________ tests are all working again.

Thank you!
Back to top
View user's profile Send private message
KS-Soft



Joined: 03 Apr 2002
Posts: 11782
Location: USA

PostPosted: Mon Feb 15, 2016 10:05 am    Post subject: Reply with quote

You are welcome

Regards
Alex
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    KS-Soft Forum Index -> Bug reports All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

KS-Soft Forum Index